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Smooth Transition from CADSTAR
to Altium Designer Develop
For the purpose of this migration guide we are going to focus on importing CADSTAR Schematic and PCB Designs, if 
you require other files migrated please refer to their specific guide.

Legacy Translation

Before You Start to Import

This guide will show you how to import data from your legacy system into Altium Designer Develop. What it will not ask 
is “why do you want to do it?” Customers frequently ask about data import facilities before we go forward however we 
need to ask ourselves why.

So, after considering these points you should read on if you still wish to import your legacy data into Altium.

• Does the data include all necessary information to
create a robust representation within Altium?

• Is it easier to “draw a line in the sand” and start new
designs in the new system rather than re-work the
imported data to make it usable?

• How do you maintain library integrity?

• Who has design authority?

• How do you plan to verify the data?

• How do you plan to verify the imported data?

• How much re-work is going to be allowed after
importing?

• Do you need to take advantage of additional features
of Altium once imported and how do you plan to
achieve this?

• Are there any exotic parts that you may have trouble
representing within Altium?

• Do you need to add Altium-specific features (like 3D
models) for every part?

• How much redundancy, duplication and error is
present in your library?

We have 20 years of data and I don’t 
want to leave it behind.

Our service bureau doesn’t use Altium 
but they can import Altium data. Our 
Altium system can import their data, 
is this a reliable way to pass designs 
between our companies?

We have a library of trusted parts which 
we’d like to bring into Altium.

We have some ‘golden’ designs that 
we need to bring into Altium Designer 
Develop so that we can up-issue them.
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Preparing to Migrate Your Legacy Data
Never forget that migration of data follows the «garbage in….more garbage out» principle. So we need to consider four 
distinct phases of the process, this is best shown in the flow diagram below:

Step 1: Prepare Original Data - Pre-Translation Tidy Up

It is prudent to clean and tidy your design within your legacy system before trying to export. We’ve put together a check 
list to help you: 

Schematic considerations

•	 Single pin components representing power objects?

•	 Connectors represented as one-gate-per-pin with 
over 256 «gates».

•	 Ambiguous connectivity.

•	 Hidden pins or implicit connections.

•	 Local net names.

•	 Case sensitivity.

•	 Do the schematic symbols call up the correct PCB 
footprints?

•	 Does the schematic match the PCB?

1. Prepare original data

•	 Check content

•	 Remove redundant or confusing data

•	 Verify integrity

2. Export data

•	 Save data in a format suitable for 
import into Altium Designer Develop

3. Import data

•	 Save «raw» imported data

•	 Integrity check

4. Post import

•	 Add Altium-specific objects

•	 Tidy up

•	 Final integrity check

PCB considerations

•	 Large number of graphical objects or drawing 
primitives on documentation layers.

•	 Star point earths.

•	 Deliberate DRC violations.

•	 Objects extending beyond the environment.

•	 Known PCB layer assignments.

•	 Do the auto-named nets match with schematic?

Library considerations

•	 Schematic symbols matching with PCB footprints.

•	 Correct supply chain information and BoM.
parameters

•	 Need to import 3D information?

•	 Correct representation of custom pads, copper 
shapes, solder mask and resist?
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Step 2: Save Data in a Suitable Format

Supported Versions and File Formats

The following table details the versions of all the file types of CADSTAR Designs that can be migrated into Altium 
Designer Develop. Note that this list is updated all of the time, so please check with us for specific systems and 
versions before undertaking migration.

The importer supports up to CADSTAR version 17. The importer does not support binary CADSTAR files. The binary 
CADSTAR file must be converted to CADSTAR archive file before importing to Altium Designer Develop. The CADSTAR 
archive file has the extension .cpa or .csa. The importer supports the following CADSTAR file types:

•	 PCB design

•	 PCB component library

•	 Schematic design

•	 Part library and schematic symbol library

TYPE SYSTEM VERSION FORMAT

Schematic CADSTAR 18 ASCII (.csa)

PCB CADSTAR 18 ASCII (.cpa)

Schematic Library CADSTAR 18 ASCII (.csa) 

ASCII (.lib)

PCB Library CADSTAR 18 ASCII (.cpa)

The following table describes the types of CADSTAR files the importer supports with the description of how to convert 
CADSTAR binary files to CADSTAR archive files and the equivalent Altium Designer Develop output.

CADSTAR FILE TYPE EXPORT TO CADSTAR ARCHIVE ALTIUM DESIGNER  
DEVELOP OUTPUT

PCB design (.pcb) Use CADSTAR File->Export to convert the binary 
pcb design (.pcb) to CADSTAR PCB archive (.cpa)

Altium Designer Develop PCB 
document (.PcbDoc)

Schematic design (.scm) Use CADSTAR File->Export to convert the binary 
schematic design (.scm) to CADSTAR schematic 
archive (.csa)

Altium Designer Develop 
schematic document (.SchDoc)

PCB Library (.lib) Use the archive tool in CADSTAR Libraries->PCB 
Components... to convert the binary pcb library 
(.lib) to CADSTAR PCB archive (.cpa)

Altium Designer Develop PCB 
library (.PcbLib)

Part Library (.lib) and 
Schematic Symbol Library 
(*.lib)

The part library (.lib) file is already in ASCII file 
format. You do not need to do any conversion on 
the part library. Use the archive tool in CADSTAR 
Libraries->Schematic Symbols to convert the 
binary symbol library (.lib) to CADSTAR schematic 
archive (.csa)

The importer uses both the 
parts.lib and the symbol 
schematic archive (.csa) to 
output an Altium Designer 
Develop schematic library 
(.SchLib)
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Step 3: Import Data into Altium

Using the Import Wizard for CADSTAR Files

The Import Wizard can be launched from the Altium 
Designer Develop File menu. Choose the CADSTAR 
Designs and Libraries option as shown in the screenshot 
below. On the “Importing CADSTAR Design Files” screen, 
click the Add button to choose the CADSTAR files. 
Multiple files can be translated at the same time. Step-
by-step instructions on using the Import Wizard follow 
next.

Starting the Import Wizard for CADSTAR Files

•	 Start the Import Wizard with File » Import Wizard

Step-by-Step Import Instructions on Importing  
a CADSTAR Design

The following CADSTAR Design, has been exported from 
CADSTAR in PCB archive (.cpa) and Schematic archive 
(.csa) format.
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•	 Select Type of Files to Import—>CADSTAR Designs 
and Libraries

•	 Add the file(s) to be translated. In this case,  
both the Schematic and PCB files are going to  
be added, specifically “Reference_Design_CC2541.
CSA” and “Reference_Design_CC2541.CPA”. 
By importing them at the same time, Altium  
will automatically create a project containing 
both files.

NOTE:  
You can add as many design files at this point. However, if you add files of a different file name, 
separate projects will be created.
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In the next step you can add your Schematic or PCB 
Libraries to import (if available).

•	 Set the options for what level of reporting is done 
after the translation has completed.

NOTE:  
Because the library part and decal information is included in the source files, it is not necessary to 
add libraries for schematic or PCB files to successfully translate. Only add libraries to this screen if 
you wish to independently translate entire libraries for later use in Altium Designer Develop.
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•	 Layer Mapping

CADSTAR PCB files will be analysed before translation 
to best determine how layer definitions in CADSTAR will 
be mapped to Altium Designer Develop layers. Efforts 
will be made to ensure, for instance, CADSTAR silk layers 
map to Altium silkscreen layers. Layer mapping can 
be manually adjusted if desired. In addition, CADSTAR 
layers can be set to “No Layer” if information from a 
particular layer can be discarded. Specific to internal 
layers, CADSTAR’s inner signal layers will be initialized 
as Altium signal layers (e.g., “Mid Layer 1”). CADSTAR’s 
Powerplane layers will be initialized as Altium Plane 
Layers (e.g., “Internal Plane 1”), which are negative-
image planes similar to CADSTAR’s Powerplanes. 
CADSTAR’s inner layers defined as Split/Mixed layers will 
be initialized as Altium signal layers if any trace or other 
positive image electrical data is present. If the Split/
Mixed layer only has pour shapes it will be initialized 
as an Altium Plane layer, and imported with all split, 
embedded, and isolated plane areas intact. This setting, 
as mentioned, can be changed manually by the user.

•	 A preview of the files being translated, and their 
output directories are shown. You can change the 
main output directory if desired. 
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•	 Click the final Next button and the Import Wizard will 
take care of the rest.

•	 Congratulations, your design has now been imported 
into Altium Designer Develop! Follow the Post Import 
Tidy Up checks to ensure the design has been fully 
checked and verified. Details on how to carry out 
some of these checks can be found in the ‘Bringing 
Together Imported Schematic and PCB Designs’ 
guide.

https://docs.google.com/document/d/13VKNblKIMGV8ZAObjMJAX5oNfGH38Aof/edit
https://docs.google.com/document/d/13VKNblKIMGV8ZAObjMJAX5oNfGH38Aof/edit
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Step 4: Post Import Tidy Up

We’ve put together a verification checklist for you:

Physical check

•	 View » Fit Document

•	 Board shape and cut outs

Electrical check

•	 Netlist

Rules

•	 Have all rules been imported

•	 DRC check

•	 Check settings for polygons - Island removal,  
min primitive size

•	 Thermal reliefs, direct connect

•	 Check power plane settings

•	 Power plane Pull-back

•	 Solder mask, Paste mask rules

•	 Via Tenting

•	 Testpoint assignments

Power check

•	 Nets

•	 Planes

•	 Polygons

Documentation check

•	 Layers

•	 Text/Strings

•	 Legends

PCB reports

•	 Number of components/nets

•	 All nets routed
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Getting Help
Main article: Documentation and Help

The best way to learn is through doing, Altium and Altium Designer Develop provide a number of ways to help you do 
that:

•	 F1 over any object, editor, panel, menu entry or button to open a brief description in your web browser.

•	 Shift+F1 while running a command for a list of shortcuts you can use in that command.

•	 Search the Altium Documentation, on the Altium Website.

•	 Visit the Video Library where you can watch over 150 short training videos, each detailing the exact steps needed 
to complete a task.

https://www.altium.com/documentation/altium-designer
https://www.altium.com/documentation/altium-designer
https://altiumvideos.live.altium.com/
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See Also
Below are references to other articles and tutorials in the Altium Designer Develop Documentation Library that talk 
more about the conceptual information as well as walking you through specific tasks. Remember, you can also browse 
through the Help contents, and use F1 and What’s This at any time in a dialog for more details.

•	 For more PCB project options, refer to the tutorial, From Idea to Manufacture - Driving a PCB Design through Altium 
Designer Develop.

•	 For a tutorial that steps you through all the basics of creating components, read A Look at Creating Library 
Components.

•	 For a tutorial that steps you through all the basics of editing multiple objects, read Editing Multiple Objects.

•	 For an overview of Altium Designer Develop’s FPGA design, development and debugging capabilities,  
read Soft Design.

A great place to start your journey through all the 
new possibilities with your Altium Designer Develop 
installation. On the top left of Altium Designer Develop 
you can find the Help » Exploring Altium Designer 
Develop link

From here, you can easily access the Documentation 
where the “Getting Started with Altium Design Solutions” 
category will ease your start into using Altium.

https://www.altium.com/documentation/altium-designer/tutorial-complete-design-walkthrough
https://www.altium.com/documentation/altium-designer/tutorial-complete-design-walkthrough
https://www.altium.com/documentation/altium-designer/schematic-placement-editing-techniques
https://www.altium.com/documentation/altium-designer/schematic-placement-editing-techniques
https://www.altium.com/documentation/altium-designer/schematic-placement-editing-techniques
https://techdocs.altium.com/display/ADOH/Soft+Design

